Compiling Cumulus Quagga?

  • 4 February 2016
  • 5 replies

How to compile Cumulus Quagga on your debian system:

1) Grab source from our github tree:
git clone -b cm_2.5

2) Install necessary debian packages

apt-get install build-essential gawk automake autoconf libtool texinfo stgit binutils libreadline6-dev libjson0-dev libjson0-dbg debhelper dh-autoreconf dejagnu

3) Build debian package

dpkg-buildpackage -us -uc -d -b

4) Or Build by hand:
./configure --build=x86_64-linux-gnu --prefix=/usr --includedir=\${prefix}/include --mandir=\${prefix}/share/man --infodir=\${prefix}/share/info --sysconfdir=/etc --localstatedir=/var --libexecdir=\${prefix}/lib/quagga --disable-maintainer-mode --enable-dependency-checking --enable-exampledir=/usr/share/doc/quagga/examples/ --localstatedir=/var/run/quagga --sbindir=/usr/lib/quagga --sysconfdir=/etc/quagga --enable-vtysh --enable-isisd --enable-watchquagga --enable-ospf-te --enable-opaque-lsa --enable-ipv6 --enable-ospfclient=yes --enable-ospfapi=yes --enable-multipath=64 --enable-user=quagga --enable-group=quagga --enable-vty-group=quaggavty --enable-configfile-mask=0640 --enable-logfile-mask=0640 --enable-rtadv --enable-werror --enable-gcc-rdynamic --with-libpam
make -j10

Then you can do a make install to install

5 replies

Userlevel 1
Do you have this for a Fedora/CentOS box per chance?
Stanley put together a rpm that builds rpm's from our source I believe. I have not attempted it, but knowing Stanley it kick's ass and chew's bubblegum. The above instructions 'build by hand' should work as well.
Updated the Cumulus github repository to 2.5.6 in addition I pushed a patch that removes some debian dependencies packages that are not necessary for running on the host.
A bit off-topic, but has anyone tried to x-compile cumulus quagga for ARM using qemu. I have a small fleet of B+ raspberrys that I would like to use as endpoints. Found a post for the x-compile effort, using x86_64 architecture to build ARM images, but ran into trouble when I followed the above "build by hand" method. (BTW - instructions worked fine for an x86_64 build on debian jessie.).
Userlevel 5

Can you share your configure line? Sounds like you have a missing or incorrect config in it.