Dell diagnostics for S4048-ON


Hi there,I'm running Cumulus Linux 3.0 on the S4048-ON, which kills the diagnostics partition on the filesystem.
So I'm trying to re-install the Dell Network Diagnostics but can't find it anywhere with Dell's site?
Just wondering if anybody knows the location of this file as I need it so I can boot into the diagnostics partition and upgrade the CPLD image.
The documentation here says to do this:
ONIE:/ # onie-nos-install tftp://x.x.x.x/DND-SK-DELL-DIAG-ENTRY-UPDATER
Just I can't find that updater file??
I can download the other ONIE and BIOS files from this location and when I try to install INSTALLER-DND-SK-1.0.0.8.bin I get this error message as the /dev/disk3 partition must get created during the previous step:

ONIE:/ # onie-nos-install http://192.168.155.3/INSTALLER-DND-SK-1.0.0.8.bin
Stopping: discover... done.
Info: Fetching http://192.168.155.3/INSTALLER-DND-SK-1.0.0.8.bin ...
Connecting to 192.168.155.3 (192.168.155.3:80)
installer 100% |*******************************| 27129k 0:00:00 ETA
ONIE: Executing installer: http://192.168.155.3/INSTALLER-DND-SK-1.0.0.8.bin
Verifying image checksum ... OK.
Preparing image archive from /installer ... Done.
No Diag Partitions found.Creating Diag Partition as /dev/sda3.../tmp/tmp.oUd2mp/installer/install.sh: line 128: can't create : no
nexistent directory
/tmp/tmp.oUd2mp/installer/install.sh: line 128: can't create : nonexistent directory
3 create failed
installation /tmp/tmp.oUd2mp/installer/FTOSDIAG-SK-1.0.0.8.bin error 1
ONIE:/ #
Any information would be much appreciated.

2 replies

Userlevel 3
Hi Andy,

The problem is the original diag image did not adhere to the ONIE specification. When CL3.0 was installed, it creates the sda3 partition using the remaining disk space, after the ONIE partition. So I would suggest we start fresh by booting into ONIE rescue mode from CL using:
onie-select -rf
Then reinstall the Dell ONIE using:
onie-self-update -e http://path/to/onie-updater
The -e will "embed" the new ONIE version, and wipe the rest of the disk. Then install the diag image to fdo the firmware upgrade. Finally reinstall CL3.0.

I found this link has everything we need. The Dell instructions assume you have the files downloaded. I found them hard to find, apparently you have to click the "view details" links next to Diag and ONIE. The ONIE.zip should have the ONIE updater in it. Also we tried this in the lab, and it looks like you may have to power cycle the device after the firmware update, as ours seemed to hang. Then boot back into ONIE, and re-install CL3.0.



Post back and let us know how it works.

Cheers,
Jason
Thanks for the information, I tried your suggestion but it died with the same error.

What I did in the end was choose the onie-embed boot option and it auto discovered the diagnostics installer and created the partition.

Then I could boot into the diagnostics partition and update the dcli image.

Thanks for the help it was really useful.

Reply