Cannot see quagga directory or quagga service in Cumulus VX 3.4.1

I am trying to install VX v3.4.1 on a mac using Virtualbox, for the first time. I'm a newbie to Cumulus. I'm following the documents here:

Step 2 states to "edit the /etc/quagga/daemons file " using sudo. However, in all four instances I have launched, the quagga directory is absent. Have I missed something? Do I manually create the directory and file?


8 replies

Userlevel 2
Bill, thanks for pointing this out!

VX 3.4.x uses FRR instead of Quagga.

Replace that /etc/quagga with /etc/frr

Userlevel 3
Thanks Bill and sorry, we were busy with the NetQ launch. Kevin is right; we started using FRRouting instead of Quagga starting with Cumulus Linux/VX 3.4.0.
Update: I've updated the docs to not mention Quagga. I added a pointer on the What's New page announcing that FRR replaced Quagga in 3.4.0.
Perfect. Thank you for the prompt reply and updating the docs.
Pete, the "Create a Two-Leaf, Two-Spine Topology" doc has a reference the old directory in 4 other places. For the sake of consistency, you may like to change these as well.

Userlevel 3
Bill Efthimiou wrote:

Pete, the "

Bill Efthimiou wrote:

Pete, the "

I have upgraded some of my switches in my virtual lab and they have moved from quagga to frr in the process - it worked well 🙂

Also I have created a short and as simple as possible post on netq - any comments and corrections welcome 🙂

It's work in progress (and excludes a telemetery server as I don't have access to the VM) and I will include output from the validation commands + I will be creating other posts on the lab setup and also one day a guide on setting it all up from scratch using ZTP and Ansible.


Userlevel 4
Bill Efthimiou wrote:

Pete, the "