Question

Port speed stuck at 100m

  • 31 May 2019
  • 7 replies
  • 123 views

Build............ Cumulus Linux 3.7.6
Uptime........... 1:33:35.240000
Model............ Dellemc N3048EP
CPU.............. ARMv7 ARM ARMv7-A Cortex-A9 1.20GHz
Memory........... 2GB
ASIC............. Broadcom Helix4 BCM56340
Ports............ 48 x 1G-T_PoE & 2 x 10G-SFP+

For some odd reason, my swp47 is stuck at 100M. I can't get it to connect at 1G. It's connected to a Cisco 3850. Links are copper.

7 replies

Userlevel 4
Hi @briankoch709 in talking to one of our L1 engineers, he suggested you first disable auto-negotiation. If that doesn't work, try swapping out the cable.
Correction: You may have accidentally disabled autoneg and set speed to 100. Please see if you can re-enable autoneg.

Another option is that the Cisco may be negotiating down to 100M.
Userlevel 4
Ugh, sorry I had that backwards about auto-neg.
This is what happens when I attempt to disable autoneg:

User Timestamp Command
------- -------------------------- ------------------------------------------
cumulus 2019-05-31 23:46:21.420150 net del interface swp47-48 link autoneg on


WARNING: Couldn't create a pre-commit snapshot. These changes cannot be rolled back.
"/sbin/ifreload -a" failed:
error: swp48: cmd '/sbin/ethtool -s swp48 autoneg off speed 1000 duplex full' failed: returned 255 (Cannot set new settings: Operation not supported
not setting speed
not setting duplex
not setting autoneg
)
error: swp47: cmd '/sbin/ethtool -s swp47 autoneg off speed 1000 duplex full' failed: returned 255 (Cannot set new settings: Operation not supported
not setting speed
not setting duplex
not setting autoneg
)
Command '['/sbin/ifreload', '-a']' returned non-zero exit status 1

"net commit" failed for ifupdown2. All changes will remain in "net pending".
A couple of clarifying points to clear up the confusion:
1) Autoneg is required for 1G operation. On a fixed copper switch, autoneg is already enabled by default.
2) To force a port to 100M, you may have to disable autoneg, and set speed 100. I was suspecting that autoneg might have gotten disabled if you were in 100M mode. That may not be true.
3) When you disable autoneg, it is assumed that you will manually set all parameters:
ethtool -s swp48 speed 100 duplex full autoneg off

You will need to have autoneg correctly set to on to enable 1G operation - you can verify via ethtool swp48, at the bottom, you should see:

code:
cumulus@act-4610p-53:~# sudo ethtool swp3
Settings for swp3:
...
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 27
Transceiver: internal
Auto-negotiation: on
MDI-X: off
Link detected: yes




If Autoneg is properly set to 'on', but speed is still 100M, then there are 2 likely root causes:

A ) the neighbor (Cisco 3850) is advertising 100M only.
B ) the cable quality is bad, or does not have all 8 pins properly connected, and it only is working in 100M mode
Hi Brian. After talking with another platform developer, he pointed out on this platform that these are combo ports, meaning there is a fixed port and an SFP port that shares the same port number for swp47 and swp48. We only support the SFP port,

are you you plugging into the SFP port with an RJ45 SFP, or are you trying to use the fixed RJ45 port?

Depending on which one you are using, the answer of why it doesn’t work is either that port isn’t supported, or you may have found a bug in the way we control that port. Either way, if if doesn’t come up, please open a case with support so that we can clarify the docs or fix the bug
Replaced the cable again (3rd copper cable now), and it came up on 1G. Grrrrrrrrr.

Reply