Bonding and Trunk issue


Hi ,

I am trying to bundle my two ports like swp1 & swp2 both are 10G ports so I need the traffic to be flow as 20G so I want to do Bonding for that but if my swp1 and swp2 ports are trunk means I am not able to bond them can I know how can I achieve this thing?

4 replies

yes, it is possible,

if active bond, you might want check if LACP is talking to each other, could it be remote is not sending LACP BPUD?
Eric Dong wrote:

yes, it is possible,

if active bond, you might want check if LACP is talking to each other, cou...

Currently my up-link ports are in trunk mode and inter VLAN communication is happening, need to make that up-link ports in one bond i.e., (2x10G up-link = 20G).

Please find my topology below:

Userlevel 1
Hi Darshan,
If the ports swp1 and swp2 are already members of a trunk, then you can not enslave them. First remove the ports from the bridge, then add them to a bond, and then you can add the bond to the bridge for trunking.
So the configuration would be something like this:
#if using NCLU:
net del bridge bridge ports swp1-2
net add bond bond1 bond slaves swp1-2
net add bridge bridge ports bond1
#This will be config applied by NCLU
+auto bond1
+iface bond1
+ bond-slaves swp1 swp2
+
auto bridge
iface bridge
- bridge-ports swp1 swp2
+ bridge-ports bond1

Nipul Shah wrote:

Hi Darshan,
If the ports swp1 and swp2 are already members of a trunk, then you can not enslave t...

Thank you for your help..!!

I did this way...

net add bond bond1 bond slaves swp1-2
net add bond bond1 bridge trunk vlans <1-60000>

and it worked...!!! 🙂

Reply