Solved

Bridge l2protocol-tunnel all does not work

  • 16 March 2020
  • 5 replies
  • 181 views

Hi,

I’m tring to setup an eBGP+EVPN+VXLAN structure. The computer can ping to the other one so BGP,VXLAN,EVPN are working good. However I can not build LACP between customer’s switch(Cisco 3750).

Here is my topology with the configuration of swp15 and swp19.

[Cumulus Side]

net add interface swp15

net add interface swp15 mtu 9100

net add interface swp15 bridge access 700

net add interface swp15 bridge l2protocol-tunnel all

net add interface swp15 link autoneg off

net add interface swp15 link speed 1000

net add interface swp19

net add interface swp19 mtu 9100

net add interface swp19 bridge access 700

net add interface swp19 bridge l2protocol-tunnel all

net add interface swp19 link autoneg off

net add interface swp19 link speed 1000

[Cisco Side]

interface Port-channel1
switchport trunk encapsulation dot1q
switchport mode trunk
interface Gi1/0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active
!
interface Gi1/0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 1 mode active

I followed this article to make sure I am doing right.

1.Bridge on the VTEPs configured in 802.1ad.

   My configuration: net add bridge bridge vlan-protocol 802.1ad

2.Customer interface is 802.1Q VLAN trunk.

   My configuration: switchport trunk encapsulation dot1q

                                 switchport mode trunk

3.VTEP host facing port in access mode.

   My configuration: net add interface swp15,swp19 bridge access 700

4.Enable layer 2 protocol tunnel all.

   My configuration: net add interface swp15,swp19 bridge l2protocol-tunnel all

Here are few questions,

1.Is there any config will cause bridge l2protocol-tunnel all invalid?

2.Is there any necessary config which is not mentioned on that article?

3.CDP and PAgP are not working well either. Therefore, I change both Cisco switches to Extreme switches. LACP is not working either. BUT Extreme’s edp is working.  Hope someone can explain this.

 

Thanks!!!

 

icon

Best answer by Ta Wei 24 March 2020, 02:40

Until now, the main problem is missing a config which we need add bridge-l2protocol-tunnel all under the interface vni.

Command : net add vxlan vni700 bridge l2protocol-tunnel all

However there is still a problem to be solved on LACP convergence.

So it means that this command probably have unknown bug.

Hope someone who can explain or post the details about how to use and how it works.

Because I can not find any information about this command neither user guide nor tech document.

View original

5 replies

Userlevel 5

If this is on real hardware I would recommend opening a Support case to troubleshoot this further.

If this is in a virtual simulation for learning, I would recommend starting to use TCPdump to sniff traffic at various locations.

Until now, the main problem is missing a config which we need add bridge-l2protocol-tunnel all under the interface vni.

Command : net add vxlan vni700 bridge l2protocol-tunnel all

However there is still a problem to be solved on LACP convergence.

So it means that this command probably have unknown bug.

Hope someone who can explain or post the details about how to use and how it works.

Because I can not find any information about this command neither user guide nor tech document.

Userlevel 2

This feature was added for specific use-cases and only documented in the article that you already found. Can you tell us more about the hardware that you are using and what you mean with “convergence”? Do the LACP frames not arrive on the other end at all?

This feature was added for specific use-cases and only documented in the article that you already found. Can you tell us more about the hardware that you are using and what you mean with “convergence”? Do the LACP frames not arrive on the other end at all?

I use Lenovo NE2572O with Cumulus v3.7 and Cisco 3750X as Customer switch.

On the other hand, sorry for my ambiguous explain.

Yes, LACP frames do arrive on the other site. However when I unplug one wire of this LAG, the network need to take 60~90 seconds for recovering. Also, it takes the same time to recovery when plug it back to the switch.

I am consider that it probably caused by LACP mode.

There is a command for Cisco called lacp rate fast.

Unfortunately, I can not test this because my Cisco switch does not support this command.

In that case, I can not make sure which EVPN/VXLAN or LACP rate caused this problem.

Thanks

Userlevel 2

If the LACP frames are arriving at the other end, you can be pretty certain this is related to the connected client and not the overlay network. I don’t know the 3750 specifically, but lacp rate seems to be a standard thing to configure?

Reply