bug in 3.2.0 version for VRRP?


Userlevel 2
Trying to add VRRP between two switches using the configuration example from documentation. Whenever I try to add this line:
"net add bridge address-virtual 01:10:01:ff:fe:fd 10.10.11.254/24"
I get an error saying that the Command is not found. What am I doing wrong here?

10 replies

Userlevel 3
Troy,

I don't know about the "command not found" error, but I do know that you probably shouldn't use a virtual MAC address with the lowest bit of the first byte set. That's the bit which indicates it is a multicast address, and so packets with that destination address will be flooded. Instead of 01:10:01:FF:FE:FD, I would recommend using an address from the VRRP reserved range of 00:00:5e:00:01:00 to 00:00:5e:00:01:ff.

One possibility for the "command not found" error are that you are not using the latest version of Cumulus Linux. NCLU (the "net" command) was in early access and so may not have been available by default in your release. Can you try configuring VRR by editing /etc/network/interfaces and adding lines such as:

auto bridge.500
iface bridge.500
address 192.168.0.252/24
add
ress-virtual 00:00:5e:00:01:01 192.168.0.254/24
(NOTE: I'm having problems getting the formatting of that code snippet working. See the link.)
See this page for info on how to configure VRR without using NCLU.

Alternatively you could try "sudo apt update; sudo apt upgrade" to make sure you've got the latest Cumulus Linux code.

Scott
Userlevel 2
I am using 3.2.0, added debian wheezy package and the vrrpd ifplugd package. The switch took "net add bridge" and "net add bridge address xx.xx.xx.xx/xx" just fine. I have also tried not using a mac, using the 00:00:5e:00:01:01 mac's...no dice to everything.

Yet when I check the available commands using net help address-virtual, I see it right there in the available command list: "net add bridge address-virtual..."

Userlevel 3
You may have found a bug! Can you try adding quotes around the addresses like this:

net add bridge address-virtual "01:10:01:ff:fe:fd 10.10.11.254/24"

If that doesn't work, can you post the /etc/network/interfaces file which is generated after you run the command and get the "Command not found" error? Alternatively, if you are a Cumulus Linux customer, you can contact our customer support, and they will give you better help than I.

Scott
Userlevel 2
Well, adding quotes around the address portion worked! Thank you!
Userlevel 4
Also the vrrpd package you installed is not required for using the NCLU commands you are using. Cumulus Linux ships with VRR installed (an active/axtive) implementation. Vrrpd is not a package we maintain at present time.
Userlevel 2
could that be causing a problem?

Userlevel 4
What is broken now? It sounded like Scott's advice fixed it?
Userlevel 2
well, adding the quotes around the mac and IP address worked, but now I find that using NCLU I cannot 'undo' (for lack of a better term) vlan-aware mode and use traditional bridge mode. In other words, when I try to use a simple sub-interface such as swp37.11, I get an error that "sub interfaces are not allowed in vlan-aware mode"

However, when I create the vrrp interface using traditional bridge configuration in the /etc/network/interfaces file, it works just fine.

Userlevel 4
You can't configure bridges in traditional mode with NCLU. What is the requirement for traditional bridges? Also why are you configuring VRRP vs VRR?
Userlevel 3
Just to follow up on this, I worked with Troy through a Cumulus Support case.
The "command not found" error happens when trying to execute this command on the wrong interface. For this command to work, you have to have the bridge, and you must configure it on the bridge.subinterface of a vlan-interface.

NCLU provides a set of guard rails to ensure the user creates a working configuration. Clearly it worked here. 🙂

Reply