Question

Learning IGMP in cumulus


Similar to this topic https://forums.cumulusnetworks.com/cumulus-linux-230719/looking-to-enable-ipv4-igmp-snooping-and-ipv6-mld-on-native-untagged-vlan-1-7431676
we tried to enable igmp snooping and queirer on particular vlan as our cluster (proxmox) depends on this.
I followed suggestion on above topics but our multicast still suffered from more than 10% loss.
I also read documentation on https://forums.cumulusnetworks.com/cumulus-linux-230719/looking-to-enable-ipv4-igmp-snooping-and-ipv6-mld-on-native-untagged-vlan-1-7431676 but I found some command missing from our NCLU as type below
code:
auto bridge.100
vlan bridge.100
bridge-igmp-querier-src 123.1.1.1

1 reply

Userlevel 4
Hi @riizzz it looks the NCLU option needs to be whitelisted.

Edit /etc/netd.conf and remove `bridge-igmp-querier-src`from the line at the bottom of the file. Restart the netd service after.

$ sudo systemctl restart netd.service

Let me know if that does the trick!

Reply