Solved

poed DBG settings?

  • 23 July 2018
  • 1 reply
  • 167 views

It seems since release 3.4.2 or so we're seeing the following messages pretty consistently across our ports using POE.

2018-07-23T16:52:51.688341+00:00 DSW511-BKLN poed: DBG : swp3: update_power False => True
2018-07-23T16:52:51.692968+00:00 DSW511-BKLN poed: DBG : swp3: update_tlv False => True
2018-07-23T16:52:51.697496+00:00 DSW511-BKLN poed: DBG : lldp pause
2018-07-23T16:52:51.795933+00:00 DSW511-BKLN poed: DBG : swp3: ['lldpcli', 'configure', 'ports', 'swp3', 'dot3', 'power', 'pse', 'class', 'class-4', 'supported', 'enabled', 'powerpairs', 'spare', 'type', '2', 'source', 'primary', 'priority', 'low', 'requested', '0', 'allocated', '0']
2018-07-23T16:52:51.798392+00:00 DSW511-BKLN poed: DBG : swp3: update_power True => False
2018-07-23T16:52:51.802853+00:00 DSW511-BKLN poed: DBG : lldp resume
2018-07-23T16:52:51.838716+00:00 DSW511-BKLN poed: DBG : lldp cfg update

I assume this is just a logging level change or behavior change & is not indicative of any problem (all of our PoE devices are functioning fine/the same as always).
I've searched through the documentation and the related man pages for both poed & lldpd but I do not see anything in the conf files for those to control the logging level (again, assuming this is just a logging issue).
Any insight on an approach to reduce the "noise" in the logs/get just info or notice level logs on these vs debug?
icon

Best answer by Dave Olson 23 July 2018, 19:32

Yes, it was a change to help debug problems.

The logging code doesn't appear to have a way to disable logging debug level messages, although from the way the code is written, it looks like that was the original intent.

I'd suggest opening a support case to add that ability; that part of the code is still the same in 3.6.2.

You *could* edit /usr/sbin/poed to make the dbg log routine not log anything, but that will be overwritten on an upgrade. Or you could filter out the messages in a new custom rsyslog config file in /etc/rsyslog.d/
View original

1 reply

Userlevel 3
Yes, it was a change to help debug problems.

The logging code doesn't appear to have a way to disable logging debug level messages, although from the way the code is written, it looks like that was the original intent.

I'd suggest opening a support case to add that ability; that part of the code is still the same in 3.6.2.

You *could* edit /usr/sbin/poed to make the dbg log routine not log anything, but that will be overwritten on an upgrade. Or you could filter out the messages in a new custom rsyslog config file in /etc/rsyslog.d/

Reply