adding a route on /etc/frr/frr.conf doesn't show up immediately


adding a route through the NCLU, does create an entry on frr.conf, and the route shows up when i hit 'ip route show / net show route'. but doing it vice-versa doesn't work



7 replies

jus tried it on 3.5 too, i think the route shows up only after a restart
Userlevel 3
So if you configure the route with NCLU then run 'net show route' followed by 'ip show route' the route doesn't show up in frr.conf? Does the route show up if you configure the route with NCLU then run 'net show route' only?
yup pete, however it works now, after restarting the frr service - cumulus@switch1:~$ sudo systemctl restart frr.service
Userlevel 3
Interesting, thanks for letting me know. I'll tell our support team about this.
Userlevel 1
Shakir,

How are you editing frr.conf? There are two ways to do this:
1. Edit /etc/frr/frr.conf using a text editor like nano or vi
2. Use the vtysh to apply configuration directly

For #1, a sudo systemctl reload frr.service is required as FRR needs to read in the changes to the configuration file. This is not the same as restart , as reload only looks at the difference in the configurations and applies them.

For #2, vtysh applies the configuration changes immediately. Make sure to do a wr mem in this method otherwise the configuration won't be persistent.

hi rama, I tried the first option, now I understand from you that reload is sufficient, instead of a restart. so, does the restart option interrupt routing for that moment? when do we normally go with the restart option
Userlevel 1
Correct, you should always be using reload when applying configuration changes.

Restart is only used when enabling FRR for the first time. Restart can be disruptive as it may create a new PID for the service, whereas reload only applies configuration changes to the existing FRR process.

Reply