CLAG use SWITCHD?


Userlevel 1
I have worked with Cumulus before and ran into very little issue with any implementation; however with CumulusVX I have. I understand SWITCHD is not supported; however I see articles about using CLAG/MLAG with CumulusVX. Does CLAG need SWITCHD? I reeceive the following error on the /var/log/clagd.log:

Aug 11 09:08:20 CumulusVX-01 clagd[4843]: Beginning execution of clagd version 1.1.0
Aug 11 09:08:20 CumulusVX-01 clagd[4843]: Invoked with: /usr/sbin/clagd --daemon 169.254.255.2 peerlink.4094 44:39:39:FF:40:94 --priority 32768
Aug 11 09:08:20 CumulusVX-01 clagd[4849]: Role is now secondary
Aug 11 09:08:20 CumulusVX-01 clagd[4849]: unhandled exception: Traceback (most recent call last):#012 File "/usr/sbin/clagd", line 3012, in main#012 ClagRun()#012 File "/usr/sbin/clagd", line 2969, in ClagRun#012 Bcm = BcmSupport()#012 File "/usr/sbin/clagd", line 2813, in __init__#012 super(BcmSupport, self).__init__()#012 File "/usr/lib/python2.7/dist-packages/bcmshell.py", line 68, in __init__#012 raise ValueError("socket %s does not exist" % socketname)#012ValueError: socket /var/run/switchd.socket does not exist
Aug 11 09:08:20 CumulusVX-01 clagd[4849]: exit with status 3

Please any help would be appreciated.

7 replies

Userlevel 1
####CUMULUSVX-01####
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.11.5
netmask 255.255.255.240
gateway 192.168.11.1

auto peerlink
iface peerlink
bond-slaves swp1 swp2
bond-mode 802.3ad
bond-mode 802.3ad
bond-miimon 100
bond-use-carrier 1
bond-lacp-rate 1
bond-min-links 1
bond-xmit-hash-policy layer3+4

auto peerlink.4094
iface peerlink.4094
address 169.254.255.1/30
clagd-enable yes
clagd-peer-ip 169.254.255.2
clagd-sys-mac 44:39:39:FF:40:94

auto br
iface br
bridge-vlan-aware yes
bridge-ports peerlink
bridge-stp on
bridge-vids 1000-3000
bridge-pvid 1
bridge-mcsnoop 1

####CUMULUSVX-02####
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet static
address 192.168.11.6
netmask 255.255.255.240
gateway 192.168.11.1

auto peerlink
iface peerlink
bond-slaves swp1 swp2
bond-mode 802.3ad
bond-mode 802.3ad
bond-miimon 100
bond-use-carrier 1
bond-lacp-rate 1
bond-min-links 1
bond-xmit-hash-policy layer3+4

auto peerlink.4094
iface peerlink.4094
address 169.254.255.2/30
clagd-enable yes
clagd-peer-ip 169.254.255.1
clagd-sys-mac 44:39:39:FF:40:94

auto br
iface br
bridge-vlan-aware yes
bridge-ports peerlink
bridge-stp on
bridge-vids 1000-3000
bridge-pvid 1
bridge-mcsnoop 1

Userlevel 1
It should work, but you may need to tweak the configuration slightly. Have you seen our pre-built MLAG demo: https://github.com/CumulusNetworks/cumulus-vx-vagrant/tree/master/vagrant/demos/mlag

It's complex but if you run it, you can take a look at the resulting configuration that's applied to the Cumulus VX virtual machines and see how it's done.
Userlevel 1
Yes I did see that; however I have yet to run it.

Userlevel 1
I also get a [failed] on service clagd status
Userlevel 1
Figured it out. Under peerlink.4094 you NEED to add clagd-args -vm (this is only need for VM's)

Example:
auto peerlink.4094
iface peerlink.4094
address 169.254.255.2/30
clagd-enable yes
clagd-peer-ip 169.254.255.1
clagd-sys-mac 44:39:39:FF:40:94
clagd-args -vm
Userlevel 3
Thanks for providing your solution,@DJL88. We did mention this in the release notes (https://support.cumulusnetworks.com/hc/en-us/articles/207128867#rn298), but I think we might be better off surfacing this in more places.
Userlevel 3
DJL88: I'm glad you were able to figure that out. I've updated the article about using Vagrant and MLAG to specifically call out the fact that this parameter is required on VMs.

Also, one minor but important point, the "vm" argument must be proceeded by two dashes, not one, as you show in your example, above. So the corrected example would be:
auto peerlink.4094
iface peerlink.4094
address 169.254.255.2/30
clagd-enable yes
clagd-peer-ip 169.254.255.1
clagd-sys-mac 44:39:39:FF:40:94
clagd-args --vm

Reply