configure ospf


Hi All,
I am trying to configure simple OSPF on Cumulus VX. I have 2 spine and 2 leaf topology. All IPs are pinging.
Quagga service is started properly.
when I go into Quagga shell to configure OSPF parameters, it takes all commands nicely. However when I run "show running-config' it doesn't show anything at all.
I can't get OSPF running.
Any idea what might be the cause?

Thanks in advance.

4 replies

Userlevel 4
Is quagga have the OSPF daemon running? Cat /etc/quagga/daemons, maybe only zebra is on. Ospfd=yes will do it then restart the daemon (service quagga restart)
Userlevel 2
Are you using a process ID when putting in the ospf command, for example
router ospf 1   
The syntax is valid, but Cumulus Linux does not support multiple OSPF instances, my guess is you need to configure OSPF without a process ID

router ospf
network 10.1.1.0/24 area 0
The other possibility is that OSPF is not enabled within the Quagga daemons file. Make sure ospfd=yes is set

$ cat /etc/quagga/daemons
zebra=yes
bgpd=yes
ospfd=yes
Pete Lumbis wrote:

Are you using a process ID when putting in the ospf command, for example

router ospf 1   
You got it pete. I was giving an instance id to ospf.
without it, is working now...

Thank you very much.... Much appreciated.
Hi Sean,
Yes OSPFd is working and enable. I have enabled zebra and ospfd both.

zebra=yes
ospfd=yes

its quite strange. its taking all the commands but not updating the configuration. 😞

thanks

Reply