Could use some help getting the .qcow2 VX 3.0.0 file working

I previously had VX 2.5.6 working great, and I downloaded and set up VX 3.0.0 identically to my previous install (I used the setup guide found here). What I'm encountering is that I can see the Grub loader, and part of the boot process, but then it goes to a blank screen with a flashing cursor. No login prompt, or anything. It just sits there. I redownloaded the file, double-checked the file sizes and sha1sums, and they're identical. Any ideas what I've done wrong?

11 replies

I'm having the same issue. I'm trying the Vagrant box version but I'm trying to run that image interactively in VirtualBox to troubleshoot the problem. Blank screen after boot loader prompt. I've tried removing console references to ttys0 and ttyS0 with no luck. The symptoms with vagrant up are timeouts when trying to ssh.
Hmm.... I think I'm doing something wrong here. I interrupted the boot process, and removed the console references, but it's still booting into that blank screen.



Any idea which part I failed to delete?

I *DID* manage to get telnet access to work, via a little trickery, however. I connected Eth0 to a DHCP server VM I made, SSH'd into the VX VM, and manually edited /etc/default/grub, /etc/inittab, and confirmed ttyS0 was in /etc/securetty. After rebooting the VM, I'd get this message:

[ 4.347582] platform microcode: firmware: failed to load intel-ucode/06-06-03 (-2)

But after about 50-60 seconds, I'd reach the cumulus login prompt, and could proceed normally. I've seen something similar happen with Extreme Networks virtual EXOS VM (it gives a coreDumpWrite error), which one of their engineers confirmed wouldn't effect operation. Is this the case here, as well?
Userlevel 5
It should also be possible to just wait a bit (~60 seconds) on the serial console and get a login prompt there.
BTW, I'm really excited to check out that ONIE install simulation feature. I could only watch Dav...REALLY!? Oh that's just too cool! Can't wait to try that! *evil laugh*
Userlevel 5
BTW, I'm really excited to check out that ONIE install simulation feature. I could only watch Dav...Another thing that's cool is that there is nothing pretend about it... we have separate VX binaries that can be installed now too so the install is real and functional.
Userlevel 5
BTW, I'm really excited to check out that ONIE install simulation feature. I could only watch Dav...We're excited too! It's still pretty new so docs are light on this topic but they'll come with time. It's a bit more challenging to do virtually because we can't assume anything about how folks are simulating... We're in the process of further customizing the version of ONIE that ships in VX so it is easier to simulate with. Default ONIE has some behaviors that can be challenging for the virtual environment... HW vendors customize ONIE for their platforms all the time... with VX as a platform we must make some customizations for the VX platform's version of ONIE too just like any other HW vendor might. Fun Stuff 🙂
BTW, I'm really excited to check out that ONIE install simulation feature. I could only watch David install the image on a physical switch, so it'll be fun to at least pretend like I can install the OS! 🙂
Oh cool! Thanks Eric! I'll add a MicroCore VM I have to a topology, and then try this out. If everything pans out, I'll fire up 3.0.0 outside GNS3, so I can use it to create a baseline VM. 😃
Thanks! Pica8 was cool enough to loan me one of their switches, and I've taken David Bombal's CumulusVX course, so I'm looking forward to making some really cool test labs! :D

Yup! I followed that guide to getting the KVM image working in GNS3, and 2.5.6 worked great!

I've tried using TightVNCViewer and Telnet (with gnome-term and SecureCRT ) for the VX 3.0.0 instances, since I run GNS3 in Linux Mint, but it's been a no-go, since I installed 3.0.0.
Userlevel 5
Andrew, just saw your piece here --> Very cool!

Are you referring to this guide? -->

I haven't done a lot with KVM directly, I'm typically working through Libvirt as the orchestrator to drive KVM/QEMU but I can take a peek and ask around. Which mechanism are you using to login... the serial console?