Question

Cumulus VX and GNS3

  • 17 January 2019
  • 3 replies
  • 203 views

I installed the Cumulus VX 3.7.2 appliance in GNS3 2.1.11, but the instructions for configuring don't work. I am following https://docs.cumulusnetworks.com/display/VX/Getting+Started. Is this the right guide? I then followed the KVM/Qemu section at https://docs.cumulusnetworks.com/display/VX/Libvirt+and+KVM+-+QEMU. It fails trying to install libvirt because the apt-add-repository command cannot be found. Any help is greatly appreciated.

3 replies

Userlevel 4
That's the correct guide. But the command you want to use is `add-apt-repository` (not `apt-add-repository`)
I tried both. I tried add-apt-repository and then flipped it since the other apt commands follow a similar format. Both of them reported command not found. Am I doing something wrong? Does it matter that I'm running GNS3 inside VM Workstation Pro 15? VM Workstation Pro 15 is running inside Win10, which is running on VM Fusion 11. I originally tried getting Cumulus running on my Win10 laptop running Worksation player 15 and 14 and Workstation Pro 15 and 14. . Both had issues so I figured I would try this. I have seen posts where people said they got it working, but I followed these instructions and cannot get it to work because of this issue with installing libvirt. Any help is greatly appreciated.
Userlevel 4
One of our systems engineers mentioned that GNS3 provides a whole Cumulus VX experience in a single appliance. No need for VMware.

Reply