Error after added clag-id paramater


Userlevel 1
Hello,

I am running testing with VX (version 3.2.1) under Vmware.

However, got the following error and I put clad-id variable

"error: cmd '/bin/ip link set swp1 protodown on' failed: returned 2"

But it will run fine after I remove it. Does any thing I do wrong setup. Following is my config for reference.

=====================
auto swp1
iface swp1
mstpctl-portadminedge yes
mstpctl-portnetwork no
link-speed 100
link-duplex full
alias Test port 1
mstpctl-bpduguard yes

auto swp2
iface swp2
mstpctl-portadminedge yes
mstpctl-portnetwork no
link-speed 100
link-duplex full
alias Test port 2
mstpctl-bpduguard yes

auto bond0
iface bond0
mstpctl-portnetwork no
bond-miimon 100
bond-lacp-rate 1
bond-min-links 1
bond-slaves swp1 swp2
alias Test bond0
bond-mode 802.3ad
bond-xmit-hash-policy layer3+4
clag-id 2000

auto br0
iface br0
alias vlan aware bridge
bridge-vlan-aware yes
bridge-ports bond0
bridge-stp yes
bridge-vids 1000-1100
==========================

Thanks!

7 replies

Userlevel 4
There is nothing invalid about configuring a clag-id under a bond. However it does not make sense to configure a CLAG-ID without also configuring CLAG. So you probably want to configure a peerlink and a CLAG instance to run across it. See --> https://docs.cumulusnetworks.com/display/DOCS/Multi-Chassis+Link+Aggregation+-+MLAG#Multi-ChassisLin...
I'm actually having a similar problem. I am using cumulus linux in GNS3 via Virtual box on an Ubuntu machine. After configuring the peerlink on both sides, the switchport sends an error of illeagal loopback on {slave interface name} check to make sure all adapters are connected to 802.3ad compliant switchports. Is this just an issue with the Virtual Machines?
Userlevel 4
Adam Smith wrote:

I'm actually having a similar problem. I am using cumulus linux in GNS3 via Virtual box on an Ub...

Are you configuring a Clag ID on the Peerlink? (this is not required)
Userlevel 1
Adam Smith wrote:

I'm actually having a similar problem. I am using cumulus linux in GNS3 via Virtual box on an Ub...

Please also config the port speed and duplex. I also have similar before to get suck about 802.3ad error message

Userlevel 4
Adam Smith wrote:

I'm actually having a similar problem. I am using cumulus linux in GNS3 via Virtual box on an Ub...

Virtualbox is typically using the virtio interface driver which disregards the port speed and duplex settings so those should not be required in the virtual environment (they're basically ignored when you set them).
Userlevel 1
Yes, it should be a design for running under pair of MLAG peerlink switch. After I need peerlink config it work now. Thanks for comment

So is it means I need including clag-id when config under peerlink switchs?

or

I don't need to includ clag-id when running under single switch?

Thanks!
Userlevel 1
machiasiaweb wrote:

Yes, it should be a design for running under pair of MLAG peerlink switch. After I need peerlink...

That's right. Clag-id is an mlag requirement, and not to be used in non-mlag bond configurations.

See here: https://docs.cumulusnetworks.com/display/DOCS/Multi-Chassis+Link+Aggregation+-+MLAG#Multi-ChassisLin...
"In order for MLAG to operate correctly, the peer switches must know which links are dual-connected, or are connected to the same host or switch. To do this, specify a clag-id for every dual-connected bond on each peer switch; the clag-id must be the same for the corresponding bonds on both peer switches ..."