having problem installing ldap-utils package


I am using the latest cumulus VX (3.0.1).

root@cumulus:~# apt-get install ldap-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
ldap-utils : Depends: libldap-2.4-2 (= 2.4.31-2+deb7u2) but 2.4.40+dfsg-1+deb8u2 is to be installed
E: Unable to correct problems, you have held broken packages.

3 replies

Userlevel 2
Hey Tao, did you happen to try to install the dependent items?

Userlevel 3
This looks like you downloaded lidap-utils from somewhere (perhaps added normal jessie-debian to your sources.util, but didn't also add the security repository from debian jessie)? libldap is in the cumulus jessie mirror, but ldap-utils is not.

There was a security update for libldap, and therefore the libldap version we have in our mirror is newer than the ldap-utils version that you are trying to use. You need to pick up the matching ldap-utils.

For example, when I download ldap-utils, I get:
{quote}
apt-get download ldap-utils
Get:1 http://mirrors.ocf.berkeley.edu/debian/ jessie/main ldap-utils amd64 2.4.40+dfsg-1+deb8u2 [188 kB]

and the Depends line in that package is:
Depends: libc6 (>= 2.14), libgnutls-deb0-28 (>= 3.3.0), libldap-2.4-2 (= 2.4.40+dfsg-1+deb8u2), libsasl2-2
{quote}
That version installs just fine with the version of libldap in the cumulus repository
After I add the security repository to the my sources.list, I successfully installed ldap-utils package. Thank you so much.

Reply