Solved

Is Cumulus ML2 plugin campitible with Openstack Rocky release?

  • 31 May 2019
  • 6 replies
  • 177 views

I am testing the Cumulus Neutron ML2 driver for an upcoming installation at a client. I am using the latest code on https://github.com/CumulusNetworks/networking-cumulus and Openstack Rocky release. I see error messages in neutron-server.log that ends with:

ERROR neutron.service File "/opt/stack/venv/neutron-20190417T131756Z/lib/python2.7/site-packages/networking_cumulus/version_abstract.py", line 47, in get_db_read_sess
ERROR neutron.service return db_api.get_reader_session()
ERROR neutron.service AttributeError: 'module' object has no attribute 'get_reader_session'

I just want to ask if there are any known compatibility issues with the Cumulus ML2 driver and Openstack Rocky release?
icon

Best answer by Radhika 31 May 2019, 22:15

Cumulus ML2 driver is not compatible with Openstack Rocky release. It is compatible with Openstack Queens release
View original

6 replies

Cumulus ML2 driver is not compatible with Openstack Rocky release. It is compatible with Openstack Queens release
Thanks for clarifying this.
Hello Radhika

Do you confirm that the last ML2 driver version is backward compatible with Pike ?

Thank you
Userlevel 4
@patrickm I just checked with @Radhika and it is backwards compatible with Pike.
Thank you very much, Pete !
Userlevel 4
You're welcome Patrick!

Reply