Question

nclu cannot delete bgp neighbor config if there is a vrf vni mapping in frr.conf

  • 21 July 2019
  • 2 replies
  • 78 views

Hi,

I am not sure if this is already a known issue.
I was doing an automation using Ansible and encounter strange bug that it seems nclu cannot delete a bgp neighbor configurations even though the configurations is exist, if there is a vrf vni mapping in frr.conf.

code:
cumulus@leaf1:mgmt-vrf:~$ net show version
NCLU_VERSION=1.0-cl3u29
DISTRIB_ID="Cumulus Linux"
DISTRIB_RELEASE=3.7.7
DISTRIB_DESCRIPTION="Cumulus Linux 3.7.7"
cumulus@leaf1:mgmt-vrf:~$ net show conf bgp

frr version 4.0+cl3u13

frr defaults datacenter

hostname leaf1

username cumulus nopassword

service integrated-vtysh-config

log syslog

vrf tenant1
vni 104000
exit-vrf

vrf tenant4
vni 104001
exit-vrf

router bgp 64582
bgp router-id 192.168.0.1
bgp bestpath as-path multipath-relax
neighbor spine peer-group
neighbor spine remote-as external
neighbor spine capability extended-nexthop
neighbor swp20 interface peer-group spine
neighbor swp21 interface peer-group spine

address-family ipv4 unicast
redistribute connected route-map LOOPBACK_ROUTES

address-family l2vpn evpn
neighbor spine activate
advertise-all-vni

route-map LOOPBACK_ROUTES permit 10
match interface lo

line vty

cumulus@leaf1:mgmt-vrf:~$ net del bgp neighbor swp20 interface peer-group spine
'router bgp 64582' configuration does not have 'neighbor swp20 interface peer-group spine'


And if I delete the vrf vni mapping the del bgp neighbor command worked:

code:
frr version 4.0+cl3u13

frr defaults datacenter

hostname leaf1

username cumulus nopassword

service integrated-vtysh-config

log syslog

router bgp 64582
bgp router-id 192.168.0.1
bgp bestpath as-path multipath-relax
neighbor spine peer-group
neighbor spine remote-as external
neighbor spine capability extended-nexthop
neighbor swp20 interface peer-group spine
neighbor swp21 interface peer-group spine

address-family ipv4 unicast
redistribute connected route-map LOOPBACK_ROUTES

address-family l2vpn evpn
neighbor spine activate
advertise-all-vni

route-map LOOPBACK_ROUTES permit 10
match interface lo

line vty

cumulus@leaf1:mgmt-vrf:~$ net del bgp neighbor swp20 interface peer-group spine
cumulus@leaf1:mgmt-vrf:~$ net pending
--- /run/nclu/frr/frr.conf.scratchpad.baseline 2019-07-21 04:58:22.938000000 +0000
+++ /run/nclu/frr/frr.conf.scratchpad 2019-07-21 04:58:22.940000000 +0000
@@ -3,21 +3,20 @@
hostname leaf1
username cumulus nopassword
service integrated-vtysh-config
log syslog
router bgp 64582
bgp router-id 192.168.0.1
bgp bestpath as-path multipath-relax
neighbor spine peer-group
neighbor spine remote-as external
neighbor spine capability extended-nexthop
- neighbor swp20 interface peer-group spine
neighbor swp21 interface peer-group spine
!
address-family ipv4 unicast
redistribute connected route-map LOOPBACK_ROUTES
exit-address-family
!
address-family l2vpn evpn
neighbor spine activate
advertise-all-vni
exit-address-family


net add/del commands since the last "net commit"
================================================

User Timestamp Command
------- -------------------------- -----------------------------------------------------
cumulus 2019-07-21 04:58:22.941047 net del bgp neighbor swp20 interface peer-group spine

2 replies

Userlevel 4
Hi @Reynold this is being tracked in release note 1492, which is getting published today here. Thank you for the report! We're working on a fix.
Userlevel 4
Here's the link to the release note.

Reply