Question

nclu cannot delete whole bgp config

  • 21 July 2019
  • 3 replies
  • 84 views

Hi,

I am not sure if this is already a known issue.
When deleting a whole bgp config using nclu, it does not replace the content of frr.conf and the committed config is on the frr.conf.sav file

code:
 cumulus@leaf1:mgmt-vrf:~$ net show version
NCLU_VERSION=1.0-cl3u29
DISTRIB_ID="Cumulus Linux"
DISTRIB_RELEASE=3.7.7
DISTRIB_DESCRIPTION="Cumulus Linux 3.7.7"
cumulus@leaf1:mgmt-vrf:~$ net del bgp autonomous-system 64582
cumulus@leaf1:mgmt-vrf:~$ net commit
--- /run/nclu/frr/frr.conf.scratchpad.baseline 2019-07-21 05:13:23.563000000 +0000
+++ /run/nclu/frr/frr.conf.scratchpad 2019-07-21 05:13:23.564000000 +0000
@@ -1,30 +1,12 @@
frr version 4.0+cl3u13
frr defaults datacenter
hostname leaf1
username cumulus nopassword
service integrated-vtysh-config
log syslog
-router bgp 64582
- bgp router-id 192.168.0.1
- bgp bestpath as-path multipath-relax
- neighbor spine peer-group
- neighbor spine remote-as external
- neighbor spine capability extended-nexthop
- neighbor swp20 interface peer-group spine
- neighbor swp21 interface peer-group spine
- !
- address-family ipv4 unicast
- redistribute connected route-map LOOPBACK_ROUTES
- exit-address-family
- !
- address-family l2vpn evpn
- neighbor spine activate
- advertise-all-vni
- exit-address-family
-end
route-map LOOPBACK_ROUTES permit 10
match interface lo
end
line vty

end


net add/del commands since the last "net commit"
================================================

User Timestamp Command
------- -------------------------- -----------------------------------
cumulus 2019-07-21 05:13:23.565519 net del bgp autonomous-system 64582
cumulus@leaf1:mgmt-vrf:~$ net show conf bgp

frr version 4.0+cl3u13

frr defaults datacenter

hostname leaf1

username cumulus nopassword

service integrated-vtysh-config

log syslog

router bgp 64582
bgp router-id 192.168.0.1
bgp bestpath as-path multipath-relax
neighbor spine peer-group
neighbor spine remote-as external
neighbor spine capability extended-nexthop
neighbor swp20 interface peer-group spine
neighbor swp21 interface peer-group spine

address-family ipv4 unicast
redistribute connected route-map LOOPBACK_ROUTES

address-family l2vpn evpn
neighbor spine activate
advertise-all-vni

route-map LOOPBACK_ROUTES permit 10
match interface lo

line vty


Notice the configuration is still there. But the committed configs is in frr.conf.sav file

code:
cumulus@leaf1:mgmt-vrf:~$ sudo cat /etc/frr/frr.conf.sav
frr version 4.0+cl3u13
frr defaults datacenter
hostname leaf1
username cumulus nopassword
service integrated-vtysh-config
log syslog
route-map LOOPBACK_ROUTES permit 10
match interface lo
line vty



The current workaround when automating using Ansible is to delete the whole bgp config using nclu module then use the copy module to replace the frr.conf content from frr.conf.sav and reload the frr service

3 replies

Userlevel 4
Thanks @Reynold we're aware of an issue like this and are currently working on it. Thanks for letting us know!
Hi @Pete B thanks for the reply, there is another nclu issue that I encounter during the BGP EVPN deployment testing using Ansible, would you able to look into it? here is the link. Thanks again for the response and really appreciate the help.
Userlevel 4
Will do @Reynold; thanks for letting me know!

Reply