Only partial communication - VMware Fusion


Hi. I've setup the leaf/spine standard topology and configs using OSX+Vmware Fusion. After setting up "dedicated" networks per each leaf/spine p2p link, i was able to correctly establish OSPF adjacencies, and all seemed ok.

However this is the behaviour i'm experiencing:
- None of the switchs can be reached using the 10.2.1.x addressing.
- From leaf1 swp3 interface to leaf2 interface swp3 traffic is flowing without any issues.

Some outputs from leaf1:

leaf-1# sh ip ospf neighbor

Neighbor ID Pri State Dead Time Address Interface RXmtL RqstL DBsmL
10.2.1.3 1 Full/DROther 31.937s 10.2.1.3 swp1:10.2.1.1 0 0 0
10.2.1.4 1 Full/DROther 37.997s 10.2.1.4 swp2:10.2.1.1 0 0 0

leaf-1# sh ip routeCodes: K - kernel route, C - connected, S - static, R - RIP,
O - OSPF, I - IS-IS, B - BGP, P - PIM, T - Table,
> - selected route, * - FIB route

K>* 0.0.0.0/0 via 192.168.56.2, eth0
C * 10.2.1.1/32 is directly connected, swp2
C * 10.2.1.1/32 is directly connected, swp1
O 10.2.1.1/32 [110/0] is directly connected, lo, 00:12:41
C>* 10.2.1.1/32 is directly connected, lo
O 10.4.1.0/24 [110/10] is directly connected, swp3, 00:12:39
C>* 10.4.1.0/24 is directly connected, swp3
O>* 10.4.2.0/24 [110/30] via 10.2.1.3, swp1 onlink, 00:07:44
* via 10.2.1.4, swp2 onlink, 00:07:44
O 192.168.56.0/24 [110/20] via 10.2.1.3, swp1 onlink, 00:07:43
via 10.2.1.4, swp2 onlink, 00:07:43
C>* 192.168.56.0/24 is directly connected, eth0

leaf-1# ping 10.4.2.1
PING 10.4.2.1 (10.4.2.1) 56(84) bytes of data.
64 bytes from 10.4.2.1: icmp_seq=1 ttl=63 time=1.47 ms
64 bytes from 10.4.2.1: icmp_seq=2 ttl=63 time=0.838 ms

leaf-1# ping 10.2.1.2PING 10.2.1.2 (10.2.1.2) 56(84) bytes of data.

--- 10.2.1.2 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4004ms

leaf-1# ping 10.2.1.3
PING 10.2.1.3 (10.2.1.3) 56(84) bytes of data.

^C
--- 10.2.1.3 ping statistics ---
3 packets transmitted, 0 received, 100% packet loss, time 2002ms

leaf-1# ping 10.2.1.4
PING 10.2.1.4 (10.2.1.4) 56(84) bytes of data.
^C
--- 10.2.1.4 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

So, is this normal?

Am i'm doing something wrong here?

thanks for support.

Best Regards

Jose

2 replies

Userlevel 4
Can you include your Quagga configuration here as well? My first thought is missing network statements.... but config will prove/disprove.
Hi, and thanks for the reply.

Here's the current config:

## Leaf-1
hostname leaf-1
username cumulus nopassword
!
interface swp1
ip ospf network point-to-point
!
interface swp2
ip ospf network point-to-point
!
router-id 10.2.1.1
!
router ospf
ospf router-id 10.2.1.1
redistribute connected
network 10.2.1.1/32 area 0.0.0.0
network 10.4.1.0/24 area 0.0.0.0
!
line vty
!

## Leaf-2
hostname leaf-2username cumulus nopassword
!
interface swp1
ip ospf network point-to-point
!
interface swp2
ip ospf network point-to-point
!
router-id 10.2.1.2
!
router ospf
ospf router-id 10.2.1.2
redistribute connected
network 10.2.1.2/32 area 0.0.0.0
network 10.4.2.0/24 area 0.0.0.0
!
line vey
!

## spine-1

log file /var/log/quagga/quagga.loglog timestamp precision 6

service integrated-vtysh-config

interface swp1
ip ospf network point-to-point

interface swp2
ip ospf network point-to-point

router-id 10.2.1.3

router ospf
ospf router-id 10.2.1.3
redistribute connected
network 10.2.1.3/32 area 0.0.0.0

## spine-2

log file /var/log/quagga/quagga.loglog timestamp precision 6

service integrated-vtysh-config

interface swp1
ip ospf network point-to-point

interface swp2
ip ospf network point-to-point

router-id 10.2.1.4

router ospf
ospf router-id 10.2.1.4
redistribute connected
network 10.2.1.4/32 area 0.0.0.0

Thanks

Reply