Testing redistribute neighbor in VX


Hi Team,
I'm interested in Cumulus and tried a GNS3 setup with VX to test redistribute neighbor.
I'm using pure L3 via OSPF unnumbered and same anycast GW across all leafs however I can't even get Host3 to ping Host4 on same Leaf!
I can see all the Hosts IPs are getting redistributed as /32s and can reach all Hosts from Spines.
Leaf config sample:

interface lo
address 10.0.0.5/32
interface swp1
address 10.0.0.5/32
ip ospf network point-to-point
interface swp2
address 10.0.0.5/32
ip ospf network point-to-point
interface swp6
address 192.168.0.1/32
interface swp7
address 192.168.0.1/32
ip import-table 10
router ospf
ospf router-id 10.0.0.5
redistribute table 10
network 10.0.0.5/32 area 0.0.0.0
network 192.168.0.1/32 area 0.0.0.0
route-map REDIST_NEIGHBOR permit 10
match interface swp6
route-map REDIST_NEIGHBOR permit 20
match interface swp7
ip protocol table route-map REDIST_NEIGHBOR

Am I missing something?

7 replies

Userlevel 4
What does your routing look like on the hosts? Do you have default routes applied facing the leafs? Can you show the host routing tables?
Thanks for your response Eric. I'm simulating the hosts via IOS routers both host3 and 4 have default routes pointing to swp6 and swp7 respectively. I tried on the hosts /32 and /24 with same results I also suspected something wrong with GNS3 but I can reach from any leaf both hosts addresses!
'''
Host3#sh ip route | beg Gate
Gateway of last resort is 192.168.0.1 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.0.1
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, GigabitEthernet0/0
L 192.168.0.2/32 is directly connected, GigabitEthernet0/0

Host4#sh ip route | beg Gate
Gateway of last resort is 192.168.0.1 to network 0.0.0.0
S* 0.0.0.0/0 [1/0] via 192.168.0.1
192.168.0.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.0.0/24 is directly connected, GigabitEthernet0/0
L 192.168.0.4/32 is directly connected, GigabitEthernet0/0
'''
Userlevel 4
What do the spine routing tables look like?
Also what do the routing configs look like "cat /etc/quagga/Quagga.conf; cat /etc/frr/frr.conf" ?
'''
cumulus@leaf5:~$ sudo cat /etc/frr/frr.conf
frr version 3.1+cl3u2
frr defaults datacenter
ip import-table 10
username cumulus nopassword
!
service integrated-vtysh-config
!
log syslog informational
!
interface swp1
ip ospf network point-to-point
!
interface swp2
ip ospf network point-to-point
!
router ospf
ospf router-id 10.0.0.5
redistribute table 10
network 10.0.0.5/32 area 0.0.0.0
network 192.168.0.1/32 area 0.0.0.0
!
route-map REDIST_NEIGHBOR permit 10
match interface swp6
!
route-map REDIST_NEIGHBOR permit 20
match interface swp7
!
ip protocol table route-map REDIST_NEIGHBOR
!
line vty
'''
I don't have Quagga. How to verify the proxy arp is working (a debug on the host simulated by router shows encap failure he seems not receiving arp reply).
Userlevel 4
Tarik wrote:

'''
cumulus@leaf5:~$ sudo cat /etc/frr/frr.conf
frr version 3.1+cl3u2
frr defaults datacenter
ip ...

Proxy arp should not be required for standard Redistribute Neighbor however to check whether or not proxy arp is enabled on any of your interfaces you can use the 'sudo sysctl -a | grep "proxy_arp =" ' command.
Tarik wrote:

'''
cumulus@leaf5:~$ sudo cat /etc/frr/frr.conf
frr version 3.1+cl3u2
frr defaults datacenter
ip ...

Is 0 output normal?
'''
net.ipv4.conf.all.proxy_arp = 0
net.ipv4.conf.default.proxy_arp = 0
net.ipv4.conf.eth0.proxy_arp = 0
net.ipv4.conf.lo.proxy_arp = 0
net.ipv4.conf.swp1.proxy_arp = 0
net.ipv4.conf.swp2.proxy_arp = 0
net.ipv4.conf.swp3.proxy_arp = 0
net.ipv4.conf.swp4.proxy_arp = 0
net.ipv4.conf.swp5.proxy_arp = 0
net.ipv4.conf.swp6.proxy_arp = 0
net.ipv4.conf.swp7.proxy_arp = 0
net.ipv4.conf.swp8.proxy_arp = 0
'''
Thanks
Userlevel 4
Tarik wrote:

'''
cumulus@leaf5:~$ sudo cat /etc/frr/frr.conf
frr version 3.1+cl3u2
frr defaults datacenter
ip ...

Yes. Proxy arp is not enabled by default.

Reply