Vagrant 1.9.1 issues with Cumulus VX plugin


Vagrant 1.9.1 seems to have broke the plugin. After installing the plugin you cannot add any box into Vagrant:

korova@nuc:~/Vagrant Projects$ vagrant box add cumuluscommunity/cumulus-vx
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

cannot load such file -- bundler
korova@nuc:~/Vagrant Projects$ vagrant box add bento/centos-7.2
Vagrant failed to initialize at a very early stage:

The plugins failed to load properly. The error message given is
shown below.

cannot load such file -- bundler
korova@nuc:~/Vagrant Projects$ vagrant plugin uninstall vagrant-cumulus
Uninstalling the 'vagrant-cumulus' plugin...
Successfully uninstalled vagrant-cumulus-0.1
korova@nuc:~/Vagrant Projects$ vagrant box add bento/centos-7.2
==> box: Loading metadata for box 'bento/centos-7.2'
box: URL: https://atlas.hashicorp.com/bento/centos-7.2
This box can work with multiple providers! The providers that it
can work with are listed below. Please review the list and choose
the provider you will be working with.

1) parallels
2) virtualbox
3) vmware_desktop

Enter your choice: 2
==> box: Adding box 'bento/centos-7.2' (v2.3.1) for provider: virtualbox
box: Downloading: https://atlas.hashicorp.com/bento/boxes/centos-7.2/versions/2.3.1/providers/virtualbox.box
==> box: Successfully added box 'bento/centos-7.2' (v2.3.1) for 'virtualbox'!

2 replies

Userlevel 5
Kelly,

The vagrant-cumulus plugin is not needed unless you are creating networks inside of the vagrant setup. So with Vagrant 1.9.1 you should be able to setup instances without it. Let me know if your experience differs.

Thanks,

Scott
Hello,

I just got the same error, here is the stack trace I got while running the plugin in debug mode:

DEBUG global: Loading plugin 'vagrant-cumulus' with default require: 'vagrant-cumulus' DEBUG global: Failed to load plugin 'vagrant-cumulus' with default require.
DEBUG global: Loading plugin 'vagrant-cumulus' with slash require: 'vagrant/cumulus'
ERROR global: Plugin loading error: LoadError - cannot load such file -- bundler
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require'
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require'
DEBUG global: /Users/afressancourt/.vagrant.d/gems/2.2.5/gems/vagrant-cumulus-0.1/lib/vagrant-cumulus.rb:3:in ''
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require'
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require'
DEBUG global: /opt/vagrant/embedded/gems/gems/vagrant-1.9.1/lib/vagrant.rb:312:in 'block in '
DEBUG global: /opt/vagrant/embedded/gems/gems/vagrant-1.9.1/lib/vagrant.rb:308:in 'each'
DEBUG global: /opt/vagrant/embedded/gems/gems/vagrant-1.9.1/lib/vagrant.rb:308:in ''
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in 'require'
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:128:in 'rescue in require'
DEBUG global: /opt/vagrant/embedded/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:39:in 'require'
DEBUG global: /opt/vagrant/embedded/gems/gems/vagrant-1.9.1/bin/vagrant:62:in '
'
ERROR vagrant: Vagrant experienced an error! Details:
ERROR vagrant: # shown below.


cannot load such file -- bundler>

Reply